3.5" Waveshare TFT works on first boot, not on reboot

Overview Forums Sticky Finger’s Kali-Pi 3.5" Waveshare TFT works on first boot, not on reboot

This topic contains 4 replies, has 2 voices, and was last updated by  roadwarrior 2 weeks, 5 days ago. This post has been viewed 126 times

  • Author
  • #13717


    Hi all,

    Kali-Pi newbie here. Downloaded the latest img, wrote to SD card. Booted fine with desktop on monitor. Ran kalipi-tft-config to set up my TFT. Set boot options to auto login user pi to CLI. Works fine on reboot after that, but on subsequent reboots I get a blank black TFT. I do get text on bootup and shutdown but it seems to go blank right about the time you’d expect a touch interface to appear.

    Where do I start debiggiong this?


  • #13741


    I’m having the same exact issue with my Waveshare 3.5 (A). if I boot it up with the HDMI connected to a monitor it boots fine. Right now I’m updating the kernel to see if that does anything and then Remove the Display settings, Reboot, Reinstall display setup and reboot again. Sometimes doing that gets it running but after reboot goes back to showing text on boot and then going to black. I’ll update if I figure it out.

  • #13742


    I can confirm now that it works if you update the kernel. Here is what I did:

    From the kalipi-tft-config
    On Boot options set it up so it boots into command with the user pi
    Update Overlays
    Remove Display settings
    Setup Display settings for your specific screen
    Update Re4son Kernel with these commands:

    echo “deb http://http.re4son-kernel.com/re4son/ kali-pi main” > /etc/apt/sources.list.d/re4son.list
    wget -O – https://re4son-kernel.com/keys/http/archive-key.asc | apt-key add –
    apt update
    apt install -y kalipi-kernel kalipi-bootloader kalipi-re4son-firmware kalipi-kernel-headers libraspberrypi0 libraspberrypi-dev libraspberrypi-doc libraspberrypi-bin


    Now my Raspberry pi is booting straight to the Sticky Settings

  • #13744


    Many thanks, that worked a treat. Took two attempts to get it right but it now works every time after reboot.

  • #13745


    I’m glad i could help.

You must be logged in to reply to this topic.