A couple of issues

Overview Forums Pi-Tail A couple of issues

Viewing 4 reply threads
  • Author
    Posts
    • #12459
      gitxmax
      Participant

      Just installed “TAIL” on me Pi Zero W

      Changed “home” entry in wpa_supplicant, to match my home network and pi connected with no issues, can ssh, vnc etc.
      The issue is, despite, being connected to the home network, can’t get the internet working on pi.

      Also, tried adding the wlan1 interface (722n v1) with the entry below wlan0:

      allow-hotplug wlan1
      iface wlan1 inet dhcp
      wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

      Iwconfig and ifconfig show the interface, but, it wouldn’t connect to home network.
      I renamed the current wpa_supplicant file and recreated wpa_supplicant with:
      “wpa_passphrase <Your SSID> >> /etc/wpa_supplicant/wpa_supplicant.conf”

      wlan1 then connected to my home network, but, also, could not get any internet connection.

      I run a few other pi’s with re4son (non tail) images, and they have no similar issues.

      Thanks

    • #12461
      gitxmax
      Participant

      Just to add, setgw command had no effect..

    • #12471
      Re4son
      Keymaster

      Hi gitxmax,

      Let me retrace your steps tonight and see where it gets stuck.
      Do you mind sending me your “/boot/interfaces”?

      Many thanks,
      Re4son

    • #12500
      gitxmax
      Participant

      Thanks for your attention.

      Have changed nothing from the default, only replaced “home” in wpa_supplicant, to match my hotspot.

      Another test I made,
      Clean install of Pi-Tail.
      Removed pre-configured wpa_supplicant, interfaces files.
      Put my own interfaces file, containing only:

      auto wlan0
      allow-hotplug wlan0
      iface wlan0 inet dhcp
      wpa-ssid xxx
      wpa-psk xxxxx

      As I always do, on my clean installs, for simple configuration and connecting to wifi on first boot. This always works with re4son pre-build images.

      In this case, the connection to homework was successful, but, once again, no internet connection.

      Strangely, running setgw, return 10.42.0.145 as the default gw, where as my router is 10.42.0.1. I tried setting the default gw manually, to 10.42.0.1, which succeeded, but still, no internet connection established.

      Thanks again!

      P.S. Found the culprit.
      /etc/resolv.conf has 9.9.9.9 for nameserver, changing it to my router ip, fixed the issue.

    • #12501
      Re4son
      Keymaster

      Good news, thanks for letting me know.

Viewing 4 reply threads
  • You must be logged in to reply to this topic.