Auto login Kali-pi not working

Overview Forums Sticky Finger’s Kali-Pi Auto login Kali-pi not working

Viewing 7 reply threads
  • Author
    Posts
    • #12558
      Lvoutlaw
      Participant

      Hello world,
      I used the pre installed image for Kali-pi
      Set up the adafeuit 2.8r (touch working)
      Tried to use the -a pi
      Keeps booting to loggin screen
      What should I look into

    • #12559
      Re4son
      Keymaster

      Hi Lvoutlaw,

      Until 10 minutes ago, the auto-login function was only for cli mode. I’ve extended it now to include gui.
      It’ll now detect whether the Pi is set to boot into cli or gui and will configure auto-login for that mode.
      Just update it via:
      cd /usr/local/src/re4son-kernel_4* && ./re4son-pi-tft-setup -u

      And try again.

      Thanks for the motivation.
      I’ve wanted to finish this off for a while but never came around to do it.

      Many thanks,
      Re4son

    • #12565
      Lvoutlaw
      Participant

      Re4son,
      Thank you so much for the update. i hope to learn as much as possible from your resource

    • #12566
      Lvoutlaw
      Participant

      Re4son,
      Update worked perfectly
      Thank you again

    • #13197
      C0rvu5
      Participant

      Hi Re4son,

      Im having some trouble with the auto login still.

      Ive tried the solution listed above and im still getting thr log in screen.

      Any ideas please?

      P.S thank you for putting this whole thing together, you sir, are a legend.

      Edit: resolved! Step 8 from this (minus the whole creating a new user) https://null-byte.wonderhowto.com/how-to/set-up-headless-raspberry-pi-hacking-platform-running-kali-linux-0176182/

    • #13472
      sirrand
      Participant

      When following the directions to enable autologon I get the following:

      root@kali-pi:/etc/pam.d# cd /usr/local/src/re4son-kernel_4*
      root@kali-pi:/usr/local/src/re4son-kernel_4.9.80-20180616# sudo ./re4son-pi-tft-setup -a pi
      [AUTOLOGON] Disabling autologon
      sed: can’t read /etc/systemd/system/getty.target.wants/getty@tty1.service: No such file or directory

      I then followed the steps outlined in this article quoted by previous user:

      “Edit: resolved! Step 8 from this (minus the whole creating a new user) https://null-byte.wonderhowto.com/how-to/set-up-headless-raspberry-pi-hacking-platform-running-kali-linux-0176182/”

      Yet, I still get a login prompt. Any tips to get this feature running?

    • #13484
      sirrand
      Participant

      UPDATE:

      Got some progress by running:

      systemctl enable getty@tty1.service

      This got me past the ‘No such file or directory”. Still not quite working correctly.

    • #13485
      Re4son
      Keymaster

      Hi sirrand,

      No need to do any of that anymore. Just run

      kalipi-config

      And select
      “03 Boot Options” -> “B1 Desktop / CLI”
      Choose your preferred option and you’re all set

      Hope that helps,
      Re4son

Viewing 7 reply threads
  • You must be logged in to reply to this topic.