Different resolution forced on desktop

Overview Forums Pocket-Kali Different resolution forced on desktop

Viewing 2 reply threads
  • Author
    Posts
    • #13029
      fireqt
      Participant

      Hi,

      Following your recommendation on the kali forums I’ve installed the latest pocket kali and updated to the current 4.15.12 stable, battery seems to work quite well so I’m very happy about it so far, thanks a lot.

      There is one issue with screen resolution though. On my Acer One 10 I have a native resolution of 1200×1900 (smartphone-like screen orientation, when rotated this is my equivalent of 1900×1200), and while on the login screen I get my native resolution as expected, when logging in to any user on any desktop setting, my resolution switches to 1152×720.

      I do get a flicker when logging in so it actually changes the resolution, and the difference once logged in is also very visible. Tried to change scaling, but it really is a resolution difference.

      It isn’t just a default setting issue, as when I go to the Display settings, it still shows 1200×1920 as currently active, and while xrandr tells me that in reality 1152×720 is my current resolution (which sounds plausible), when trying to set it back to 1200×1920 xrandr accepts the command but does nothing, like if it was already the active resolution. If it change it to something else then ‘back’ to 1200×1920, I get the same incorrect resolution as after logging in.

      In short, it seems like when I log into my desktop a different resolution is forced, which cannot be changed back to my native as the system already believes it is set. Quite frustrating tbh.

      Should I update to 4.16? This is a fresh install after a complete format, only thing I’ve done is to update the kernel to latest stable.

      xrandr log below:

      root@kali:~# xrandr
      Screen 0: minimum 320 x 200, current 1152 x 720, maximum 8192 x 8192
      DSI-1 connected primary 1152x720+0+0 right (normal left inverted right x axis y axis) 0mm x 0mm
         1200x1920     60.54*+
         1920x1200     59.95  
         1920x1080     59.93  
         1600x1200     60.00  
         1680x1050     59.95    59.88  
         1600x1024     60.17  
         1400x1050     59.98  
         1280x1024     60.02  
         1440x900      59.89  
         1280x960      60.00  
         1360x768      59.80    59.96  
         1152x864      60.00  
         1024x768      60.04    60.00  
         960x720       60.00  
         928x696       60.05  
         896x672       60.01  
         960x600       60.00  
         960x540       59.99  
         800x600       60.00    60.32    56.25  
         840x525       60.01    59.88  
         800x512       60.17  
         700x525       59.98  
         640x512       60.02  
         720x450       59.89  
         640x480       60.00    59.94  
         680x384       59.80    59.96  
         576x432       60.06  
         512x384       60.00  
         400x300       60.32    56.34  
         320x240       60.05  
      DP-1 disconnected (normal left inverted right x axis y axis)
      HDMI-1 disconnected (normal left inverted right x axis y axis)
      DP-2 disconnected (normal left inverted right x axis y axis)
      HDMI-2 disconnected (normal left inverted right x axis y axis)

      Thanks you

    • #13030
      Re4son
      Keymaster

      Hi fireqt,

      The Pocket-Kali image sets the resolutions through the following autostart script:

      cat ~/.config/autostart/xrandr.desktop 
      
      [Desktop Entry]
      Exec=/usr/bin/xrandr --output DSI-1 --scale 0.65x0.65
      Icon=system-run
      Path=
      Name=xrandr
      Terminal=false
      Type=Application

      You can either:

      1. Change the resolution in that file if you require a fractional scaling, or
      2. use the scaling factor in the display setting and delete the file if a whole number suffices

      I you want to completely rid the system of the xrand autostart script you also have to delete it in “/etc/skel/.config/autostart/”

      Hope that helps,
      Re4son

    • #13031
      fireqt
      Participant

      Thank you once again, this was it. Setting to 1×1 changed to proper resolution.

Viewing 2 reply threads
  • You must be logged in to reply to this topic.