GNOME-shell Freezes

Overview Forums Pocket-Kali GNOME-shell Freezes

Viewing 5 reply threads
  • Author
    • #12943


      I am just wondering whether anyone noticed occasional slowdowns with gnome shell? E.g. when logging in just after starting up your GPD (after putting in root/password at the GDM login screen), a few seconds later you will see that it’s like the screen freezes however things are still working. I am on the latest stable and mainline kernels with everything updated to the latest version (as of 20 March 2018, 2258hrs Australian Standard Time).

      Using top, htop or conky, I have noticed that gnome shell is the main culprit so would just like to ask if anyone have also noticed this and whether anyone have found a solution to it.

      FYI, I have another respun non-Kali Linux running on another GPD also running GNOME but it does not show such behaviour. And yes, I have reinstalled Kali Pocket a few times. Another use also confirmed with me that he has the same issue as well.

      It’s not a deal breaker but would be nice if this pesky bug gets squashed. I have tried several tips over the Internet that deals with gnome-shell showing such behaviour but they were all pre-gnome-3.26 hence it was a shot in the dark anyway.

    • #12946

      Just chiming in here, as I’ve experienced the same issues. Sometimes, the screen simply doesn’t update for a few seconds, and then it’s all back to normal. It doesn’t really seem matter what I’m doing at the time.

    • #12947

      Yes, I have been experiencing the same. Currently running kernel version 4.15.7-re4son+_1, haven’t tested with 4.16-rc3-re4son+_1 yet.

    • #12976

      Very annoying, I agree.
      I haven’t found the culprit yet but I’m definitely working on it.

      Would you mind helping me by installing one of my kernels on one of the other respun images that doesn’t show this behaviour and see if the problem follows? I would much appreciate it.

      Many thanks,

    • #12990

      Hello again,

      Sorry for posting late. This was supposed to be posted 3 days ago :-). Having a daughter who loves chocolates and easter bunnies are my excuses this time round 😛

      I have done the following:-

      1. I have installed re4son’s kernel, both stable and mainline, on the non-Kali Pocket which is also running on GNOME-shell. There were no issues/slowdowns. It was run on both GNOME 3.26 and now GNOME 3.28.

      2. I have run the same kernel from my non-Kali pocket machine and installed it on the Kali pocket machine. The two kernels I have tested on this were the latest generic 4.16-rc7 and 4.15.7 kernels. The problem still remains the same with the freezes/slowdowns.

      This confirms my suspicion when I first noticed this back some months ago that this is not related to re4son’s kernels but something else on either Kali Pocket itself or the upstream distribution itself.

      Hope that helps.

    • #13008

      Maybe it’s related to power saving options? I fiddled around with tlp to disable WiFi power saving:

      Maybe there’s something for the CPU as well, that could cause this?

Viewing 5 reply threads
  • You must be logged in to reply to this topic.