Kuman 3.5" HDMI problems

Overview Forums Sticky Finger’s Kali-Pi Kuman 3.5" HDMI problems

Viewing 6 reply threads
  • Author
    • #13439

      When I try to configure the Kuman 3.5″ HDMI board on my RPi 3 it seems to go into a loop where the Kali logo is shown, screen blanks, back to the logo. I’m going to do a fresh install now to see if I can better troubleshoot this but am I correct in assuming that wave35h is the correct type to select when configuring?

      It is this board:

      Kuman 3.5″ HDMI Display-B 480×320 Dots V1.0

    • #13440

      Oh, also my menu config is this:

      export KPSCREENSIZE=3.5 ## Screensize in inch, Options= 5.0, 3.5, 2.8
      export KPLAYOUT=9 ## Number of buttons – Currently only 9 is supported
      export KPPIN=0 ## Set to “1” to enforce PIN authentication, run ./set-p$
      #export KPTIMEOUT=2 ## Minutes before screensaver kicks in, comment out for $
      export KISMETVER=1 ## Set to “2” to launch kismet github version, “1” to us$
      export TFT=3 ## Set to “0”: no TFT screen,

      I’m unsure about TFT, but 3 is the only one that even shows the Kali logo (vs a blank screen)

    • #13497

      I’d like to chime in here as well. I have a pi 3 B+ with a Kuman 3.5″ TFT. I am using the latest sticky fingers kali image https://whitedome.com.au/re4son/download/sticky-fingers-kali-pi/

      I took the following steps:
      Flashed 32GB card.
      Booted (sreen works no touch)
      SSH’d over eth0
      updated and dist-upgraded
      updated kalipi-config
      (passwords changed, wlan enabled etc, enable autologin console for user pi)
      updated kalipi-tft-config
      updated the third party repos

      Configured kalipi-tft-config as Wave35h.

      Configured the menu options as above.

      System boots on console as expected, kalipi image comes up. Screen goes dark.

      I then changed the system to boot to GUI. Screen comes up, touch interface works.
      Calibration is off. Still unable to get the menu to run as pi user on the display.

    • #13542

      I have this issue as well. It would be great if mr. Re4son could comment on what is going wrong here.

      I’ve gotten to the same point as OldManNiko, I installed and updated the latest Sticky Fingers pre-made image. I ran kalipi-config and set it to autologin in console with the user “pi” and configured the screen as Wave35h in kalipi-tft-config. On reboot I can see systemd load but as soon as it runs the menu the screen goes blank and there is nothing that can be done.

      Here are some things I’ve noticed and tried:
      – kalipi-tft-config also offers Kuman 3.5″ screen as a configuration option but when I select it I get the error “Program error: Unrecognised option”. Is this a bug?
      – If I configure the screen as Wave35h the touchscreen works but the calibration is off. Moving a finger on the screen up and down moves the cursor sideways and vice versa, plus the location is off. I tried to configure the screen with xinput-calibrator but for some reason the calibration didn’t get fixed.
      – If I run ./menu (in /home/pi/Kali-Pi) from a graphical session as root I can get the pygame menu to run in a window, but if I boot to cli as root and run it from there I get stuck in that black screen.

      I would really, really appreciate any suggestions on how to solve this problem.

    • #13543

      Hi all,

      Sorry for the late reply. I hoped that the wave35h would be suitable and I didn’t have any kuman hdmi screens to test. Pity that the calibration is off.
      The kuman 3.5 in the list is a GPIO display, not hdmi so that won’t work.

      To fix that, I’ve just ordered this one:
      I will integrate it as soon as it arrives. Will probably take a couple of weeks though coming from China. Sorry for that.

    • #13545

      No worries, I’m happy to beta test anything you got. Thank you.

    • #13546

      Thanks for the reply Re4ason! If you need any testing, etc, I’m of course ready to do that as well.

Viewing 6 reply threads
  • You must be logged in to reply to this topic.