Monitor Mode dont work

Overview Forums Sticky Finger’s Kali-Pi Monitor Mode dont work

Viewing 2 reply threads
  • Author
    Posts
    • #13727
      user7
      Participant

      I have a RaspberryPI Zero W.
      Monitor Mode dont work with your image, dont matter if you do “mon0up” or airmon-ng start wlan0. mon0(or something with another name) will not created.
      airodump-ng will not run on wlan0.
      Tryed:
      StickyFingers-Kali-Pi-armel-180924.img
      kali-linux-2019.2-rpi0w-nexmon.img
      And of course your manual installation (the old stable one, the new one doesnt work at all with Raspbian Jessi).
      Rasberry Pi is just a fixed device, not a ibm compatible computer with 10000 different kinds of hardware. Why you ppl put something in the net that is never tested? On other pages i just read about this “bootloop, black screen, doesnt work, no mon0”.

    • #13728
      Re4son
      Keymaster

      Weird, works fine for me:

      root@kali-pi:~# mon0up
      ++ Bringing mon0 up
      ++ mon0 should be up:
      4: mon0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN mode DEFAULT group default qlen 1000
          link/ieee802.11/radiotap a2:dc:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
      root@kali-pi:~# ip a
      1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
          link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
          inet 127.0.0.1/8 scope host lo
             valid_lft forever preferred_lft forever
          inet6 ::1/128 scope host
             valid_lft forever preferred_lft forever
      2: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
          link/ether a2:dc:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
      3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
          link/ether 00:e0:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
          inet 192.168.1.126/24 brd 192.168.1.255 scope global eth0
             valid_lft forever preferred_lft forever
          inet6 fexx::xxx:xxxx:xxxx:xxx/64 scope link
             valid_lft forever preferred_lft forever
      4: mon0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
          link/ieee802.11/radiotap a2:dc:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
      root@kali-pi:~# aireplay-ng -9 mon0
      21:55:40  Trying broadcast probe requests...
      21:55:40  Injection is working!
      21:55:42  Found 4 APs

      Do you know if they made any changes to their hardware?

      • #13731
        user7
        Participant

        I dont think, there is a Zero without wifi, a zero with wifi&GPIO soldered an a zero with wifi&gpio unsoldered.
        I have 2 they look same “V1.1” is on the board both bought 2019 but from
        different supplyers.
        Possible that the wifi chip has changed maybe they find a bug and changed something. Cause ppl in the internet told this doesnt work for PI3 too and they share the same wifi chip.

    • #13733
      user7
      Participant

      Found the problem.
      If you ever tryed to run airodump on wlan0, mon0up will never work(unsupported operation). Since many years airodump automatic enable the monitor modes and you dont have todo “airmon-ng start wlan0” like on the early versions.
      If you try now to run airodump in the usual way, it will quit and monup0 dont work. The same happend if you have airodump starting at runtime, it quits (before you see it) of course, wlan0 is not like usual. After it all trys with mon0up will fail.
      So if mon0up would run at startup this could maybe avoided.

      Found another bug instead, an external wifi stick will not work anymore
      with re4son kernel. Driver is there, interfaces are there, airodump starts but no packets arrive. I just wanted to compare the receive quality.
      If you want use more than 1 wifi receiver or use sometimes/at home a better
      wifi stick it will not work with this kernel.

Viewing 2 reply threads
  • You must be logged in to reply to this topic.