New ap mode: Failed to create interface mon.wlan0: -95

Overview Forums Pi-Tail New ap mode: Failed to create interface mon.wlan0: -95

This topic contains 6 replies, has 2 voices, and was last updated by  Re4son 1 year, 5 months ago. This post has been viewed 2410 times

  • Author
    Posts
  • #12316

    thaihugo
    Participant

    Hello Re4son,

    I’ve seen an update in the git where ras-ap.sh tries to launch hostapd using the nexmon drivers in monitor mode instead of reverting to normal drivers.

    However, hostapd complains that it:
    Failed to create interface mon.wlan0: -95 (Operation not supported)

    And of course the AP is not created. The script does not have any other error.

    Is this piece normally functional, or do I need to update a driver to allow the standard Kali hostapd to use the interface with nextmon drivers?

    My next step will be to add another usb interface and create a repeater with that as I was doing with the previous Kali-Pi using create_ap

    Thanks a lot for your help

    Hugo

  • #12318

    Re4son
    Keymaster

    Hi Hugo,

    it should work out of the box.

    Try:

    “install.pi-tail -i && install.pi-tail -u”

    reboot and give it another try. Works well on my end.

    Please let me know how you go.

    Many thanks,
    Re4son

  • #12320

    thaihugo
    Participant

    Hello Re4son,

    I redid it justto be sure, however Ihave the same result.

    The system log has some kernel errors too. I installed the image form your download and did simply an apt update && apt upgrade, so hostapd might be updated.

    Here is part of the (cropped, sorry about that) log:

    ce enter: mon0 type 6                                                                     NUM_NL80211_IFTYPES: (13)                                                                 pos->wdev.iftype: (2)                                                                     cfg80211_check_combinations for iftype_num: (0)        val:(0)                            cfg80211_check_combinations for iftype_num: (1)        val:(0)                            Dec 11 18:52:02 pi-tail kernel: brcmfmac: brcmf_vif_add_validate: brcmf_vif_add_validate, Dec 11 18:52:02 pi-tail kernel: brcmfmac: brcmf_vif_add_validate: brcmf_vif_add_validate, Dec 11 18:52:02 pi-tail kernel: brcmfmac: brcmf_vif_add_validate: brcmf_vif_add_validate, Dec 11 18:52:02 pi-tail kernel: brcmfmac: brcmf_vif_add_validate: brcmf_vif_add_validate, Dec 11 18:52:02 pi-tail kernel: brcmfmac: brcmf_vif_add_validate: brcmf_vif_add_validate, Dec 11 18:52:02 pi-tail systemd-networkd[151]: mon0: Gained carrier
    Dec 11 18:52:02 pi-tail systemd-timesyncd[150]: Network configuration changed, trying to eDec 11 18:52:02 pi-tail systemd-timesyncd[150]: Network configuration changed, trying to eDec 11 18:52:07 pi-tail systemd-networkd[151]: wlan0: Gained carrier
    Dec 11 18:52:07 pi-tail systemd-timesyncd[150]: Network configuration changed, trying to eDec 11 18:52:07 pi-tail kernel: brcmfmac: power management disabled
    Dec 11 18:52:07 pi-tail kernel: net_ratelimit: 13 callbacks suppressed
    Dec 11 18:52:07 pi-tail kernel: brcmfmac: brcmf_cfg80211_change_iface: brcmf_cfg80211_chanDec 11 18:52:07 pi-tail kernel: brcmfmac: brcmf_cfg80211_update_proto_addr_mode: brcmf_cfgDec 11 18:52:07 pi-tail kernel: brcmfmac: brcmf_cfg80211_add_iface: brcmf_cfg80211_add_ifaDec 11 18:52:07 pi-tail kernel: brcmfmac: brcmf_vif_add_validate: brcmf_vif_add_validate, Dec 11 18:52:07 pi-tail kernel: brcmfmac: brcmf_vif_add_validate: brcmf_vif_add_validate, Dec 11 18:52:07 pi-tail kernel: brcmfmac: brcmf_vif_add_validate: brcmf_vif_add_validate, Dec 11 18:52:07 pi-tail kernel: brcmfmac: brcmf_vif_add_validate: brcmf_vif_add_validate, Dec 11 18:52:07 pi-tail kernel: brcmfmac: brcmf_vif_add_validate: brcmf_vif_add_validate, Dec 11 18:52:07 pi-tail kernel: brcmfmac: 
    root@pi-tail:~# /opt/Kali-Pi/Menus/RAS-AP/ras-ap.sh status
    RAS-AP is running.
    /opt/Kali-Pi/Menus/RAS-AP/ras-ap.sh: line 90: return: can only 

    return’ from a function or sourced script
    root@pi-tail:~# /opt/Kali-Pi/Menus/RAS-AP/ras-ap.sh
    Usage: /opt/Kali-Pi/Menus/RAS-AP/ras-ap.sh {start|stop|status|restart}
    root@pi-tail:~# /opt/Kali-Pi/Menus/RAS-AP/ras-ap.sh stop
    —————————————
    STOP Remote Access Wifi-AP SERVICES
    —————————————
    wlan0: interface state ENABLED->DISABLED
    wlan0: AP-DISABLED
    nl80211: deinit ifname=wlan0 disabled_11b_rates=0
    Device “mon0” does not exist.
    root@pi-tail:~# /opt/Kali-Pi/Menus/RAS-AP/ras-ap.sh start
    ——————————–
    START Remote Access WiFi AP
    ——————————–
    6: mon0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN mode DEFAULT group default qlen 1000
    link/ieee802.11/radiotap b8:27:eb:xx:xx:xx brd ff:ff:ff:ff:ff:ff
    Configuration file: /opt/Kali-Pi/Menus/RAS-AP/ras-ap.conf
    Failed to create interface mon.wlan0: -95 (Operation not supported)
    wlan0: Could not connect to kernel driver

    Using interface wlan0 with hwaddr b8:27:eb:xx:xx:xx and ssid “AxxxxxT”
    wlan0: interface state UNINITIALIZED->ENABLED
    wlan0: AP-ENABLED
    root@pi-tail:~#
    `

  • #12321

    thaihugo
    Participant

    Do you need more extensive logs?

  • #12324

    Re4son
    Keymaster

    Hi Hugo,

    You can ignore the error. It is working.
    Hostapd is trying to put wlan0 into monitor mode, throws an error, and continues. It still works though because we have put it into monitor mode manually already.

    I hope that helps

  • #12327

    thaihugo
    Participant

    Hello Re4son,

    I got it.
    ignore_broadcast_ssid=1 does not broadcast a “blank” ssid as =2 does, so none of my phone can see the hidden access point. i have to create the connection manually and trust it does exist.

    Maybe a one line in the Howto to say the ap must be setup manually on the phone would be helpful?

    Thanks for your time

    Hugo

  • #12328

    Re4son
    Keymaster

    Glad it’s working.
    Thanks for letting me know – I’ll include your tip in the howto.

    Many thanks,
    Re4son

You must be logged in to reply to this topic.