Raspberry pi 3 with re4son-kernel error

Overview Forums Sticky Finger’s Kali-Pi Raspberry pi 3 with re4son-kernel error

Viewing 24 reply threads
  • Author
    Posts
    • #12049
      Alaxmofo12
      Participant

      When I do airmon-ng start wlan0 I get error adding monitor mode interface: command failed: Operation not supported (-95)

    • #12050
      Re4son
      Keymaster

      Hi Alaxmofo12,

      you can run nexutil -m2 to put wlan0 into monitor mode.

      Hope that helps,
      Re4son

    • #12051
      Alaxmofo12
      Participant

      I got Command not found.. I downloaded the 2017.1 image you have on the kern4l page and did apt-get update && apt-get upgrade. Then did apt-get install kali-linux-full. Then apt-get dist-upgrade. I don’t know if that would affect the kernel though.

    • #12052
      Re4son
      Keymaster

      Those images don’t have the nexmon drivers installed yet by default, I’m going to change that this weekend.
      You can install them by cd’ing into the kernel installation directory/nexmon/
      and follow the instructions in nexmon.txt.

      Please let me know how your go.

    • #12053
      Alaxmofo12
      Participant

      Thank you for the help dude, it works just fine.

    • #12054
      Alaxmofo12
      Participant

      Well it just stopped working Rf kill soft blocked it and when I run Rfkill unblock wlan0 it says “bogus unblock argument ‘wlan0′” <– I fixed this problem

      But nexutil -m2 was throwing socket error,bind error, and connect error.

      Now “wash -i wlan0” won’t work it says failed to compile packet filter…

    • #12055
      Re4son
      Keymaster

      Let me look into that.
      Which model pi and kernel are your using?

    • #12059
      Alaxmofo12
      Participant

      Raspberry pi 3 model b with Linux Kali 4.9.41-Re4son-v7+

    • #12061
      Re4son
      Keymaster

      I’m currently having an active “airodump-ng wlan0” session and a “wash -i wlan0” running for over 7 1/2 hours and it’s still going strong.
      What were you running when it bombed out?

    • #12063
      Alaxmofo12
      Participant

      I don’t remember what I was running so, I thought and manually removed everything from the directories that I was told to place. And redone the install and now it works. Some how nexutil got removed from /usr/bin/. No clue as to how though.

    • #12064
      Alaxmofo12
      Participant

      And I just figured out what i ran to make it bomb out.. I ran “service network-manager restart” and it completely messed it up. So had to re do what I mentioned above and it works again.And the only reason I ran the restart service command was because the network would constantly be trying to connect to my wifi

    • #12069
      Re4son
      Keymaster

      I usually completely remove network-manager to avoid these things.
      I configure my network connections via the command line. Makes it much more reliable and doesn’t do weird things when I don’t want it to.

    • #12072
      Alaxmofo12
      Participant

      Alright, thanks I might do that. Thank you for the awesome kernel and the help.

    • #12087
      Alaxmofo12
      Participant

      Alright so I just downloaded the latest image with re4son-kernel, and I go to configure the network and network manager doesn’t work. So I uninstall it and try to connect through the terminal but doesn’t work. What do you use to do it? I tried iwconfig wlan0 essid (name) key (password) and it doesn’t work. But I do iwconfig wlan0. It shows my network name, mode managed and access point: not associated.

      And how do we overclock on kali?

    • #12088
      Re4son
      Keymaster

      Just follow these steps to set up your wifi:

      https://whitedome.com.au/re4son/re4son-kernel/#Wifi

      To overclock:

      mount /boot
      nano /boto/config.txt
      # uncomment the relevant overclocking line
      reboot

      That should do the trick

    • #13661
      CoolCat
      Participant

      Hello Re4son!

      I don’t now what I can do… I have The latest Sticky Fingers… I want use The onboard wifi in monitor mode, i use iw phy phy0 interface add mon0 type monitor Everything Works fine, on “HDMI screen”… But when I do that, after installing TFT display, it does not work… I tried install on TFT everything separately… Operation not supported (-95)…
      nexutil -m2 socket errors… I tried install everything after “normal installation with HDMI” on the TFT, but nothing … The Kali Works on a different “partition” on TFT and HDMI? I’m new on Linux, and on Raspberry too… But I want to learn it:) Sorry for my Bad English, i hope you Will understant It… Thank You…!

    • #13662
      Re4son
      Keymaster

      Hi CoolCat,

      Thanks for getting in touch. Which screen are you using? I’ll try to reproduce the error.

    • #13663
      CoolCat
      Participant

      Hi Re4son!

      I use Osoyoo 3,5 non-hdmi… I use The Osoyoo “Oficial” driver, becouse with kalipi-tft-config' Osoyoo does not working... I don't know why... I choosed the Kuman 3,5 too, but nothing... We are speaking about this "display thing"...<a href="https://whitedome.com.au/re4son/topic/installing-on-osoyoo-3-5-inch/#post-13652">Osoyoo 3,5</a> I Remember, one Time is working for me The./re4son-pi-tft-setup -t wave35c -d /root` (waveshare 3,5 Clones), but the monitor mode does not working after installation display… May I choosed the worst display ever…:D So I need your help, becouse I want use The RPI “anywhere”… You now… PowerBank, mini wir. keyboard… So… “mobile” Version…:D Thank you for The fast answer…:)

    • #13668
      CoolCat
      Participant

      Omg! I don’t want write New image to SD card, after every Bad Choice… I have Osoyoo 3,5 , but it does not work… I can’t find any solution on the web… Re4son, please help me!

    • #13669
      CoolCat
      Participant

      I’m sorry, I use Osoyoo v6.3… Maybe you want this information…

    • #13673
      Re4son
      Keymaster

      I thought I had one of those laying around somewhere for testing. Let me check

    • #13674
      Re4son
      Keymaster

      Did you run “LCD35_v” to install the display drivers?

    • #13675
      CoolCat
      Participant

      Yes…

    • #13681
      CoolCat
      Participant

      I tryin’ I tryin’ but I can’t find The Solution… Via HDMI The monitor mode work perfectly, but on my Osoyoo 3,5″ nothing… The correct info, What is writed on the back side on my screen is: 3,5 inch SPI TFTLCD, 480*320 16bit/18bit, Version 6.3 2018/4/9… I think, may some things I must enable ín kalipi-config… I was try enable SPI (white screen), I2C (nothing)… Another I forget, but I Think, something i must set in config… SPI, I2C, etc… I tried The official SPI image too, only white screen… I tried The re4son, with SPI TFTLCD driver (LCD35_show) driver, with enabled and disabled SPI, but the same white screen… I don’t know whats The problem… (I want little help for you, I think, on your site on whitedom.com.au/re4son/sticky-fingers-kali-pi/ The wget… https;//….current_kernel is wrong….. Sorry If I’m Wrong) I hope you Will find something for my problem… Thank You, and have a Nice day…!

    • #13682
      CoolCat
      Participant

      I was want to say, wget adress is nőt correct… Sorry…

Viewing 24 reply threads
  • You must be logged in to reply to this topic.