TL-722N v1 not working with Pi-tail pre made image

Overview Forums Pi-Tail TL-722N v1 not working with Pi-tail pre made image

This topic contains 2 replies, has 2 voices, and was last updated by  thaihugo 1 year, 11 months ago. This post has been viewed 699 times

  • Author
    Posts
  • #12300

    thaihugo
    Participant

    Hi Re4son,

    First, thanks for your great work. You are giving us such an easier life with Kali with your kernel, and the pi-tail is a great idea for my user case scenario of working with no computer.

    I’ve been trying the pi-tail pre made image on my pi zerow. It is working properly on every type of connection.
    However, i’ve tryed to plug my trusty WL-722N v1 on a usb host converter, as I’ve been doing for month. I get a kernel error:

    ath: phy0: Mac Chip Rev 0x0f.3 is not supported by this driver
    ath: phy0: Unable to initialize hardware; initialization status: -95

    The same hardware works on Kali-pi with the same re4son kernel version (.59), on the same hardware and on my pi 3 with the same card.

    I also like to swap my sd card in my pi 3 for enhanced cpu power. With the pi-tail, i get no usb support on pi 3. Lsusb is blank as is the system log, for any hardware. No usb is registering. It is working properly on normal re4son images.

    Could you please confirm that you can get you wl-722n v1 working on pi-tail on your side?

    Also do you have any idea why the usb support for pi 3 is missing when it is existing in normal re4son kali pi zerow images?

    Thanks for your help

    Hugo

  • #12301

    Re4son
    Keymaster

    Hi Hugo,

    Thanks for your kind words. I much appreciate it.

    Comment out the line “dtoverlay=dwc2” in “boot/config.txt”. That should make all your problems go away.

    I’ve enabled this driver for mass storage and ethernet gadget mode.
    The downside is, that it doesn’t play nice with some usb network adapters.

    I hope that helps. Please let me know how you go.
    Many thanks,
    Re4son

  • #12304

    thaihugo
    Participant

    That was it.

    Thanks a lot!

    Hugo

You must be logged in to reply to this topic.