TP-LINK TL-WN722N V3 Driver / Monitor Mode / AP Mode

Overview Forums Sticky Finger’s Kali-Pi TP-LINK TL-WN722N V3 Driver / Monitor Mode / AP Mode

Viewing 9 reply threads
  • Author
    Posts
    • #12575
      Luigi
      Participant

      Hi,

      First: re4son kernel is fantastic! I use it on my Raspbian too.

      I have Kali for Raspberry with re4son kernel. I know that the WN722N V2 support is difficult, and there is a driver for using it in monitor mode. But I have TL-WN722N V3, it is new. On vendor site there isn’t driver for Linux, and I can use it only to connect to my home wi-fi (after installing firmware-realtek package).

      I can’t use in monitor mode or access point mode.
      iw list command return NULL value. Any idea?

    • #12588
      Re4son
      Keymaster

      Apparently the V3 is just a re-batched V2
      Have you tried this driver?

      https://whitedome.com.au/re4son/topic/working-wifi-adapters/#post-12139

    • #12603
      Luigi
      Participant

      Thank you for the reply.
      I have tried to install mfruba driver on my Raspbian Stretch with last version of re4son kernel, but without success.
      I find Raspbian more stable than Kali, but with Kali the usb wifi works better. So now I use Kali 2017.3, official iso, and I have read on your blog that this iso has got your kernel, so I thought that wn722n driver was already installed. I will try to install mfruba driver in Kali, I hope to have success 🙂 I will write my result.

    • #12631
      Luigi
      Participant

      Same errors of Rasbian Stretch: after the command make arch=arm, the output is

      "******************************************"
      "NO SKRC,we will use default KSRC"
      "******************************************"
      make ARCH=armv7l CROSS_COMPILE= -C /lib/modules/4.9.59-v7_Re4son-Kali-Pi+/build M=/usr/local/src/8188eu/drivers/TL-WN722N_v2.0-Ralink/rtl8188EUS_linux_v4.3.0.8_13968.20150417  modules
      make[1]: Entering directory '/usr/src/kernel'
      Makefile:628: arch/armv7l/Makefile: No such file or directory
      make[1]: *** No rule to make target 'arch/armv7l/Makefile'.  Stop.
      make[1]: Leaving directory '/usr/src/kernel'
      Makefile:1368: recipe for target 'modules' failed
      make: *** [modules] Error 2
    • #12632
      Luigi
      Participant

      In /usr/src/kernel there are the directory arm and arm64 but not arm7l

    • #12633
      Luigi
      Participant

      Ok I have used this commands:

      apt-get install firmware-realtek
      cd /usr/local/src
      git clone https://github.com/mfruba/kernel 8188eu
      cd 8188eu/drivers/TL-WN722N_v2.0-Ralink/rtl8188EUS_linux_v4.3.0.8_13968.20150417
      sudo ln -s /usr/src/kernel/arch/arm /usr/src/kernel/arch/armv7l
      make arch=arm
      make install

      Then go to /etc/modprobe.d/
      nano blacklist-8188eu.conf
      and add
      blacklist r8188eu. Save.
      Type these last commands:

      modprobe lib80211
      modprobe cfg80211
      modprobe 8188eu

      Try monitor mode, but it doesn’t work. With rfirmware-realtek the raspberry can use TP-LINK to connect to my wifi but I cannot use it for mode monitor or master.

    • #12637
      Re4son
      Keymaster

      Just ran it myself and found some errors in the instructions.

      Instead of “make arm=arch”, run

      ARCH=arm make

      When putting your interface into monitor, remember to use wlan1 on a Pi0 / Pi3

      That works for me

    • #12646
      Luigi
      Participant

      Ok, it works! I can active mode monitor and I can create an access point. Access point works well, with monitor mode I have some problems with Reaver and Wash. I will do some tests, and I will paste the output here. I will write a more ordered post soon!

      However, using my previous post, after the commands

      modprobe lib80211
      modprobe cfg80211

      You have to use

      rmmod 8188eu
      insmod /lib/modules/{kernel-directory}/kernel/drivers/net/wireless/8188eu.ko

      Then you can use mode monitor, to set it using iw phy […] command.

    • #12670
      Luigi
      Participant

      Ok, I can use WN722N as access point (Mode Master), Kali sees it (command iw dev), I can set it in Mode Monitor (command: iw phy phy1 interface add mon1 mode monitor), but it doesn’t work: Wash and Reaver don’t find WiFi. If I use airmon-ng it fails and the output says that it cannot put wlan1 in monitor mode. Any suggest?

    • #13503
      bolgal3
      Participant

      so, is it possible to somehow use the V3 of TL-WN722N for monitor mode or do I need to buy another one? Still confused…. If possible, what needs to be done?

Viewing 9 reply threads
  • You must be logged in to reply to this topic.