Upgrade issues with pure-ftpd-common

Overview Forums Sticky Finger’s Kali-Pi Upgrade issues with pure-ftpd-common

Viewing 1 reply thread
  • Author
    Posts
    • #13750
      roadwarrior
      Participant

      The last few days I’ve been ha in this constant issue when running the command “sudo apt upgrade” where after a while it stops and gives me this error:

      Errors were encountered while processing:
       /tmp/apt-dpkg-install-JzVuOL/430-pure-ftpd-common_1.0.49-1_all.deb
      E: Sub-process /usr/bin/dpkg returned an error code (1)

      I even formated the micros card, checked it for errors, reinstalled the kali image (that worked perfectly before) and re ran the upgrade command and it keeps giving me the same error. I can’t do anything right now because not only is it messing with the upgrade command but it makes all of the wifi adapters not show up (internal and 2 USB adapters). Even trying to get a 3.5 screen working on it is impossible. How can I get pass that error?

      Running “apt –fix-broken install” give some this:

      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      Correcting dependencies... Done
      The following packages were automatically installed and are no longer required:
        dconf-cli gtk2-engines-xfce hunspell-en-us libboost-system1.67.0
        libcwidget3v5 libdouble-conversion1 libdrm-etnaviv1
        libfile-readbackwards-perl libhavege1 libhttp-parser2.8
        libhunspell-1.7-0 libilmbase23 libip4tc0 libip6tc0 libjemalloc2
        liblinear3 libllvm7 libnftables0 libopenexr23 libperl5.28
        libsnmp30 libssl-dev libwireshark11 libwiretap8 libwnck-common
        libwnck22 libwsutil9 libx265-165 libxfconf-0-2 perl-modules-5.28
        python-ldap3 ruby-librex tigervnc-common
      Use 'apt autoremove' to remove them.
      The following additional packages will be installed:
        pure-ftpd-common
      The following packages will be upgraded:
        pure-ftpd-common
      1 upgraded, 0 newly installed, 0 to remove and 18 not upgraded.
      933 not fully installed or removed.
      Need to get 0 B/191 kB of archives.
      After this operation, 48.1 kB of additional disk space will be used.Do you want to continue? [Y/n] y
      Preconfiguring packages ...
      Setting up libcom-err2:armhf (1.45.4-1) ...
      Setting up libss2:armhf (1.45.4-1) ...
      (Reading database ... 245311 files and directories currently installed.)
      Preparing to unpack .../pure-ftpd-common_1.0.49-1_all.deb ...
      Unpacking pure-ftpd-common (1.0.49-1) over (1.0.47-3) ...
      dpkg: error processing archive /var/cache/apt/archives/pure-ftpd-common_1.0.49-1_all.deb (--unpack):
       unable to open '/usr/share/doc/pure-ftpd-common/README.Authentication-Modules.gz.dpkg-new': No such file or directory
      Errors were encountered while processing:
       /var/cache/apt/archives/pure-ftpd-common_1.0.49-1_all.deb
      E: Sub-process /usr/bin/dpkg returned an error code (1)
    • #13765
      zabpavel
      Participant

      My English is not very good, so sorry for the mistakes.
      Maybe I found a solution to the problem.
      This sequence of commands fixed everything for me:
      sudo apt-mark hold pure-ftpd
      sudo apt-mark hold pure-ftpd-common
      sudo dpkg --configure -a
      sudo apt-get install -f pure-ftpd
      sudo apt-get install -f pure-ftpd-common
      sudo apt-mark unhold pure-ftpd
      sudo apt-mark unhold pure-ftpd-common
      sudo dpkg --configure -a
      apt-get upgrade

      Do not scold for this approach. I’m new to this business

Viewing 1 reply thread
  • You must be logged in to reply to this topic.